Soldered Inkplate 6 Color - Help, Seller Isn't Responding

I’m doing this out of frustration, and the seller hasn’t messaged me even though I’ve tried to contact them.

I bought the (Three, actually) and had the intent to serve up my own stuff with them connected via WiFi.

The documentation is… confusing to someone new, I’ll put it that way. I’ve worked with python before, so I decided to go with the Micropython route. I’ve tried several different firmware versions - Generic ESP32, ESP32 Spiram v1.20 (latest) and even the older version that is on the soldered inkplate github.

My issue is I’m stumbling on getting the SD card to mount, and because of this I can’t run ANY examples because inside those libraries is an attempt by the os to mount the SD, and it pukes.

Its a 128GB SD card, but I made a smaller 32GB partition and formatted it as FAT32. This still doesn’t work.

I’ve tried copying over different libraries for this, trying to follow the instructions on the Soldered github – but I’m either using the wrong combination of files, or something else is going on.

Has anyone used this specific board before? I’m just going insane at the moment. The only thing I HAVE done successfully is connect it to my network via WiFi, but that’s it. I can’t draw/show anything because the examples puke, and putting in step-by-step commands in the Web REPL also dies when it comes to mounting the SD.

Help! Please. I just need a proper pointer or I’ll have to play n-factorial-bingo with all the different files listed on the page, which I’d rather not do.

I thank you in advance for helping a inkplate/micropython newbie.

@TallTim if you are still experiencing issues with this purchase can you please contact our support team at

Please be sure to provide us with any screenshots of the chat log or communications for additional context and evidence.